How do I do remote backup? (cont.)

How do I do remote backup? (cont.) From: Henk van Doorn


#!/bin/ksh
#######################################################################
# rmksysb #
#######################################################################
# #
# Description: #
# creates a bootable mksysb backup of a remote system running #
# AIX 3.x or lists the Table of Contents of the current tape #
# #
# Usage: #
# ./rmksysb $1 [$2] #
# $1 - remote host to be backed up #
# $2 - optional: local tape device (default: rmt0) #
# or: #
# ./rmksysb -l [$2] #
# to list Table of Contents saveset on tape in $2 #
# (only useful on tapes created by rmksysb) #
# #
# Output: #
# a bootable mksysb of the remote system #
# or a listing of the TOC saveset on the current tape #
# #
# Remarks: #
# . rmksysb can only be used by root #
# . this script will use tapedevice .1, so if #
# a >2.3GB drive is used: check density_set_1 #
# . the remote host needs /.rhosts to include the local host #
# for root access (+ shell enabled in /etc/inetd.conf) #
# . you will need some room (>1.5MB) on /tmp on the remote host #
# for standard mksysb .archive.list.* etc. #
# . remote standard output & standard error (except dd/chdev) #
# will go to local stdout & stderr #
# . redirecting stdout can create quite large log-files (2MB) #
# . AIX versions should not be too far apart as the boot-saveset#
# comes from the local system & the rest from the remote #
# (tested on AIX 3.2.5, AIX 4+ definitely won't work!!!) #
# . most likely this script will fail with multi-tape mksysb's: #
# another incentive to keep rootvg as small as possible! #
# #
# Author: #
# Henk van Doorn #
# Email: hvdoorn@xs4all.nl #
# #
# Thanks to all who contributed. Esp. Paul Wynn (AIXpert '93), #
# my colleagues Dominic Dinardo & Douwe van Terwisga #
# + the input from Usenet were stimulating; thanks folks! #
# I would welcome any additions & changes for the better... #
# #
#######################################################################
# CHANGES #
#######################################################################
# #
# ID WHO DATE DESCR #


Home FAQ